insert-directory function in Gnu emacs returns nil

Marc Girod marc.girod@gmail.com
Wed May 13 14:54:00 GMT 2009


Hello,

Symptom: systematically empty dired in Gnu emacs,
no error message.

I first posted as a followup to an old message reporting the same symptom,
but this only confused the matters, as the cause was then probably 
different:
http://www.nabble.com/linked-dll-data-write-copy-failed-errors-to13750118.html
linked dll data write copy failed errors 

I do suffer from bloda-like problems (intermittent vfork failures), but this
seems to be non related, since it is systematic.
I may occasionally get a vfork error too, but this is then reported.
I debugged the elisp part down to the call to:

insert-directory is a compiled Lisp function in `files'.
(insert-directory FILE SWITCHES &optional WILDCARD FULL-DIRECTORY-P)

This one just returns nil, whatever the arguments:

(insert-directory "/home/emagiro" "-la")
nil
(insert-directory "/tmp" "-la")
nil

The variable: insert-directory-program is set to the default "ls", which is
in
my path and works otherwise. Changing it to the full path doesn't affect
the behaviour.

Gnu emacs is 21.2.1, and cygwin 1.7.
I already posted my cygcheck output.

Marc
-- 
View this message in context: http://www.nabble.com/insert-directory-function-in-Gnu-emacs-returns-nil-tp23523466p23523466.html
Sent from the Cygwin list mailing list archive at Nabble.com.


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list