git-svn: perl <pid> child_copy: linked dll data write copy failed

George Reilly
Fri Oct 31 19:31:00 GMT 2008

2008/10/31 Reini Urban <>
> 2008/10/31 Eric Blake:
> > According to George Reilly on 10/30/2008 11:07 PM:
> >> I ran "ash rebaseall -v", which worked once I renamed cyglsa64.dll to
> >> a different extension.
> >>
> >> "git init" works, as does "git status" and "git svn help". But "git
> >> svn init" spews (slowly)
> >>
> >> $ git svn init
> >>       4 [main] perl 5624 child_copy: linked dll data write copy failed, 0x6FEB60
> >> 00..0x6FEB6080, done 0, windows pid 5624, Win32 error 487
> >
> > I maintain git, but have no experience with git-svn (as I choose not to
> > use svn).  It seems like 'git svn help' works because it doesn't load the
> > full perl modules in use by the bulk of the git svn command; the failure
> > seems to be that when it is finally time for perl to load additional
> > modules, then fork, that the forked copy is unable to reproduce the same
> > memory layout as the parent process, rendering the additional dlls and
> > hence the overall process dead.  This is exactly the problem that rebasing
> > is supposed to help, but since you've already tried rebasing, I have no
> > idea what else to try.

Me neither.

I'm curious. Why don't you build Cygwin DLLs with explicit base
addresses? Or why doesn't Cygwin setup automatically (offer to) do a

> And I maintain perl.
> Checkout
> and google for similar problems: antivir, duplicate cygwin dll's.

I already did. That's why I mentioned the lack of antivirus on my
machine, looking at the list of DLLs loaded in the failing Perl
process, etc.
/George V. Reilly

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list