Brand new Cygwin install on a Vista (Home Premium) machine

Karl M
Fri Oct 31 18:51:00 GMT 2008

Hi All...

I just did a fresh install of the current Cygwin 1.5 on a Vista Home Premium machine.

There were only a couple bumps. For OpenSSH, the ssh-host-config had to be run
multiple first bailed out because of the protection of the passwd and group because of the protection of /var. I think it would be good to have it offer
to fix these. I can submit a patch if desired.

The second issue was with vim from a cmd console window. When I run vim, the
arrow keys work fine until I enter insert mode...then the arrow keys alter the test
and take me out of insert mode. I've not seen this before and some Googling didn't
help. Any thoughts?

Otherwise, it was a great experience. I used the latest setup.exe snapshot and it
worked very well.

Thanks to all,


See how Windows Mobile brings your life together—at home, work, or on the go.

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list