git-svn: perl <pid> child_copy: linked dll data write copy failed

Eric Blake ebb9@byu.net
Fri Oct 31 15:46:00 GMT 2008


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

According to George Reilly on 10/30/2008 11:07 PM:
> I ran "ash rebaseall -v", which worked once I renamed cyglsa64.dll to
> a different extension.
> 
> "git init" works, as does "git status" and "git svn help". But "git
> svn init" spews (slowly)
> 
> $ git svn init
>       4 [main] perl 5624 child_copy: linked dll data write copy failed, 0x6FEB60
> 00..0x6FEB6080, done 0, windows pid 5624, Win32 error 487

I maintain git, but have no experience with git-svn (as I choose not to
use svn).  It seems like 'git svn help' works because it doesn't load the
full perl modules in use by the bulk of the git svn command; the failure
seems to be that when it is finally time for perl to load additional
modules, then fork, that the forked copy is unable to reproduce the same
memory layout as the parent process, rendering the additional dlls and
hence the overall process dead.  This is exactly the problem that rebasing
is supposed to help, but since you've already tried rebasing, I have no
idea what else to try.

- --
Don't work too hard, make some time for fun as well!

Eric Blake             ebb9@byu.net
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Public key at home.comcast.net/~ericblake/eblake.gpg
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkkLJ/MACgkQ84KuGfSFAYD0RwCgsjb2wiWGasUbyCZ4S0q002ns
2QMAnA+Vog2YN1sjOAZAYSqsDlLSRuyR
=yHbl
-----END PGP SIGNATURE-----

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list