Execute permission not set when creating files

Christopher Faylor cgf-use-the-mailinglist-please@cygwin.com
Tue Oct 28 23:29:00 GMT 2008

On Tue, Oct 28, 2008 at 10:15:45PM -0000, John Cooper wrote:
>Christopher Faylor wrote:
>>Are you sure you're using the cygwin version of all utilities?  You
>>seem to have some duplication between c:\cygwin\bin and c:\bin.
>I have a custom version of `ls' in the bin directly, but it's
>definitely the Cygwin version of `touch'.  I also get the same problem
>when I run `echo hi > b.txt':
>$ umask  
>$ type echo                                                     
>echo is a shell builtin
>echo is /c/cygwin/bin/echo
>$ echo hi > b.txt                                              
>$ ls -l b.txt                                                      
>-rw-r--r-- 1 John None 3 Oct 28 22:08 b.txt
>(btw, I've tried with zsh and bash and the problem occurs with both.)

Actually, if you try this similar exercise under linux you'll see
similar behavior.  I should have realized that before suggesting
that you had another version of touch.


Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list