problem compile with gcc

bjoe bayuadi.w@gmail.com
Fri Oct 24 10:24:00 GMT 2008


On Mon, Oct 20, 2008 at 03:05:48AM -0700, Brian Dessent wrote:
> bjoe wrote:
> 
> > The thing that confusing me is the error came from w32api packages,
> > not from source code. Maybe someone in this list can explain to me
> > about what going on here.
> 
> You haven't provided enough information, such as what version of w32api
> you're using.  If you aren't using the latest (3.12-1), first upgrade
> and see if the issue is fixed.
>
$cygcheck -c w32api
 
Cygwin Package Information
Package              Version        Status
w32api               3.12-1         OK
> If that doesn't help then we need to see the code, or a standalone
> testcase that reproduces the problem.  
$cat test.c
 
#include <windows.h>
#include <stdio.h>
#include <stdarg.h>
#include <tchar.h>
#include <security.h>
#include <secext.h>
#include <sys/stat.h>
#include <math.h>


main()
{
return 0;

}

$gcc test.c

test.c:4:19: tchar.h: No such file or directory
In file included from /usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../include/w32api/security.h:38,
                 from test.c:5:
/usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../include/w32api/sspi.h:60: error: parse error before "SECURITY_STRING"
In file included from /usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../include/w32api/security.h:39,
                 from test.c:5:
/usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../include/w32api/ntsecpkg.h:123: error: parse error before "SECURITY_STRING"
/usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../include/w32api/ntsecpkg.h:125: error: parse error before "LogonServer"
/usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../include/w32api/ntsecpkg.h:127: error: parse error before '}' token
/usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../include/w32api/ntsecpkg.h:212: error: parse error before "SECPKG_NAME_TYPE"
/usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../include/w32api/ntsecpkg.h:225: error: parse error before "SECPKG_NAME_TYPE"
/usr/lib/gcc/i686-pc-cygwin/3.4.4/../../../../include/w32api/ntsecpkg.h:342: error: parse error before "PSecurityUserData"

> It could be an #include problem,
> for example #including a header that is not meant to be included
> directly -- the MSDN page for each API function tells you which header
> to include to use that function.  And many windows headers require
> <windows.h> to be included first.
Agree, I will try to find in msdn page
>
> Brian
Thank brian


Regards
-- 
It is easy to say no when
          there is a deeper yes burning within

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list