Powershell Ouput via Cygwin and Open SSH

Nick Calvert nick.calvert@gmail.com
Sun Oct 19 17:47:00 GMT 2008


Hi guys,

I have been using Cygwin to execute Powershell scripts over SSH for a
while now... For various reasons I had to use WinSSHD for SSH which,
while a perfectly reasonable piece of software, isn't something I want
to use permanently. To experiment I built a test box using Cygwin and
OpenSSH and I'm experiencing some weird behavior.

If I SSH in and run a one liner like:

powershell get-process

... I get no output.

If I run:

powershell (...simply to launch the shell,)

I get no output.

If I run a test function that writes a text file to the root of C:,
the file is created. So essentially all of my commands are running, I
just receive no output. Cygwin via an alternative SSH server gives me
output as normal. I appreciate I've almost troubleshooted my way out
of having justification to post this here, as I would assume it's not
a Cygwin problem, but has anyone seen or heard of this before?

Thanks in advance,

Nick

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list