Trouble differentiating Backspace from Control-Backspace in rxvt-20050409-9

Jonathon Merz
Thu Dec 4 15:58:00 GMT 2008

I recently upgraded from rxvt-20050409-7 to rxvt-20050409-9 and have
stopped getting different output for Backspace and Control-Backspace.
In rxvt-20050409-7, I get ^? for Backspace and ^H for
Control-Backspace.  In rxvt-20050409-9, I get ^H for both.

I've tried explicitly setting the rxvt backspacekey to ^?, but then I
get ^? both with and without the Control key.

I've also been trying to decipher some of the documentation for
terminfo/termcap, though I'm having trouble wrapping my mind around
those, and I'm not certain whether that is the path I should go down
since my terminfo appears to be unchanged between the two.  For what
it's worth, I tried running infocmp on both the -7 and -9 versions and
got identical output for them both.

I tried looking at what changed in the source tarball between the two
versions, and nothing jumped out at me as something that would affect
interpretation of keys, though I am extremely ignorant of the inner
workings of terminal emulators, so I may have missed something.

Now for my questions: :)
First, I guess, does anyone else see this, or is it some problem with
my installation?

If it is a problem with my system, does anyone have any advice on how
I should go about debugging it?

I've also attached cygcheck output in case that is of any assistance.

Many thanks,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 14307 bytes
Desc: not available
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list