NT-Authority/System will be file owner after rsync restore

Matthias Meyer Matthias.Meyer@gmx.li
Mon Dec 1 22:15:00 GMT 2008


Larry Hall (Cygwin) wrote:
> 
> Could be.  I don't know much about rsync.  However, if that is the
> uid/gid, it maps to -1 (don't know why it's represented as a 32-bit value
> though.) Anyway, if you and I are right, then my WAG is that your
> '/etc/passwd' and/or '/etc/group' file(s) are wrong.
> See <http://cygwin.com/cygwin-ug-net/ntsec.html#ntsec-ids> for more
> details on Cygwin special IDs.
> 
Thanks Larry,

One step to the goal ;-)

I lost my /etc/passwd and /etc/group. Do not know why :-(
I create new ones with:
bin>mkpasswd -l > /etc/passwd
bin>mkpasswd -g > /etc/group

create a new file /etc/test.txt
bin>ls -alh /etc/test.txt
bin>-rwx------+ 1 meyer Kein 0 Dec  1 23:01 /etc/test.txt

Than I run a backup:
After that my backup-protocol shows:
  create   644    18/544           0 etc/Test.txt

But 18/544 is SYSTEM:Administratoren
as /etc/passwd -> SYSTEM:*:18:544:,S-1-5-18::
and /etc/group -> Administratoren:S-1-5-32-544:544:
shows.

I've tried this with both, "cygrunsrv -I backup ..." as well as
with "cygrunsrv -I backup -e CYGWIN=nontsec ..."

Any further hint?
Thanks
Matthias
-- 
Don't panic


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list