ssh ProxyCommand not finding anything to execute

SQueeZe kevin@kevinandkiran.com
Wed Sep 19 15:03:00 GMT 2007


Lets say I just drop sh.exe into the installation folder, what else would I
need to do?

I have taken the sh.exe file from a cywgin install and put it into c:\bin\,
and tried running my command again.  Now it no longer complains that it
can't find /bin/sh but it still doesn't print anything to the screen like it
should.  Obviously putting it in c:\bin isn't ideal, I need to point it to
my cwRsync directory.

I have emailed the cwRsync guys the problem but I'm not sure if they will be
willing to include sh.exe in the next release or not.

Thanks for your help
Kevin


David Rothenberger wrote:
> 
> On 9/17/2007 11:38 AM, SQueeZe wrote:
>> I have installed cwRsync which has the OpenSSH client version 4.5.
> 
> You should probably ask for support from the cwRsync project.
> 
>  > I should be able to type in the following:
>> 
>> ssh -v -o ProxyCommand="connect -H -d proxy:8085 %h 443" user@myhomepc
>> 
>> However I get the following error:
>> 
>> OpenSSH_4.5p1, OpenSSL 0.9.8d 28 Sep 2006
>> debug1: Executing proxy command: exec connect.exe -H proxy:8085 myhomepc
>> 443
>> debug1: permanently_drop_suid: 400
>> /bin/sh: No such file or directory
> 
> OpenSSH invokes "/bin/sh -c proxycmd" (see sshconnect.c line 98 in the 
> 4.7 sources) and the cwRsync package does not include sh. Even if you 
> included sh.exe in your installation directory, I doubt it would work 
> because you won't have the Cygwin mount table setup so that /bin/sh 
> would map to the correct directory.
> 
> 

-- 
View this message in context: http://www.nabble.com/ssh-ProxyCommand-not-finding-anything-to-execute-tf4469005.html#a12779359
Sent from the Cygwin Users mailing list archive at Nabble.com.


--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list