Private key file permissions w/Cygwin OpenSSH on Vista

Thu Sep 13 15:08:00 GMT 2007

Not sure if you are having the exact same issue I had, but I couldn't chmod
the files in cygwin either.  Then I realized my home directory was on a
windows share.  I was able to cp the files to my local drive and chmod them,
but the changes disappeared when moving the files back to the home
directory.  To change my home directory to a local path I ran the following
mkpasswd -l -c -p /home
this made my home directory in the local /home
once this was done I mv all files from the old network share to the local
and chmoded them appropriately and was able to use my ssh with rsa keys


Brian Dessent wrote:
> Siva wrote:
>> Re:  binary distro of OpenSSH 3.8.1p1
> If this is a reply to a previous message then please send it as an
> actual reply, don't start a new thread.  Otherwise, you break threading
> in the archives and for anyone using a threaded email client.
>> I've been unable to use Cygwin's OpenSSH on Vista w/public key
>> authentication because ssh.exe always states the file permissions on the
>> private key file--"id_rsa"--are too open.
>> I've used the chmod.exe utility to change the permissions on the id_rsa
>> file to 600, but ssh.exe still pops up with the same error message.
>> I've also used Windows' cacls.exe command to alter the ACLs for the file
>> to be ONLY read-accesible to the current user, and the same thing
>> happens.
>> This behavior DOES NOT occur on XP and 2000 when I try it, i. e.
>> chmod.exe WORKS on these OSs to change id_rsa's permissions so that
>> ssh.exe is happy (i. e. to 0600).
>> Is there a specific bona-fide way to set the id_rsa file's permission to
>> always be acceptable to Cygwin SSH on Vista, in addition to the other
>> Windows OSs?
> I can't reproduce this.  I just tried using a stock Cygwin 1.5.24 and
> OpenSSH 4.6p1-1 under Vista and it worked fine.  The default permissions
> set on the private keyfile by ssh-keygen worked without any fiddling.
> $ ls -l .ssh/id*
> -rw------- 1 brian None 1675 Jun 29 19:20 .ssh/id_rsa
> -rw-r--r-- 1 brian None  393 Jun 29 19:20 .ssh/
> So, I think you're going to need to give us a lot more information about
> your config, starting with the cygcheck output as requested at
> <>.  It would also be good to know why
> you're trying to use this very old version of OpenSSH, which might mean
> that your version of Cygwin is ancient too.
> Brian
> --
> Unsubscribe info:
> Problem reports:
> Documentation:
> FAQ:         

View this message in context:
Sent from the Cygwin Users mailing list archive at

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list