setup.exe crashes upgrading (uninstalling) bash

Brian Dessent brian@dessent.net
Tue Sep 11 14:46:00 GMT 2007


Mario Frasca wrote:

> what do you suggest?
> I already tried to reboot the system and do the update as first thing,
> but setup.exe crashes all the same...  by the way, I'm using Setup.exe
> version 2.573.2.2
> 
> if I say I want to debug the program ([Fouten opsporen]), I get here:
> 
>  004AC7CD  lea         esi,[esi]
>  004AC7D0  mov         eax,dword ptr [ebp-14h]
>  004AC7D3  mov         eax,dword ptr [eax]
>  004AC7D5  mov         dword ptr [ebp-14h],eax
>  004AC7D8  xor         ecx,ecx
>  004AC7DA  test        eax,eax
>  004AC7DC  mov         edx,5
>  004AC7E1  je          004AC7E8
> >004AC7E3  mov         ecx,dword ptr [eax+18h]

There are copies of setup with debug info included at the snapshots
site: <http://cygwin.com/setup/snapshots/>.  It would help greatly if
you could run one of them (ideally the latest) in gdb and get a
backtrace at the faulting location.  You could also attach gdb after the
fault has happened while the error dialog is on the screen.

I tried running addr2line on the above but it seems to return nonsense,
so I think we'd need more context of the call stack.

Brian

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list