1.5.24: sshd immediately disconnects upon receiving a connection

Jeremy K. Truax jeremy@trupoetry.com
Fri Sep 7 17:54:00 GMT 2007

So going off what Jim noticed about the faulty install of cygwin on Vista,
I was able to install cygwin correctly while in Safe Mode with Networking.
I installed the sshd service in Safe mode as well but you cannot start it
up until you reboot back into full mode. But then it seems to work just
fine as a service. 

As to what service might be the cause of the problem when trying to install
cygwin in Normal Windows mode, I tried narrowing down the services that
were started in Normal mode but stopped in Safe mode. As you can guess
there were many of them. I made a list of them and started shutting them
off 2-3 at a time and deleting cygwin and installing it. I got most of the
services stopped and it was still reproducing the bash.exe.stackdump every

The following services I could not stop: 
Group Policy Client (maybe it was a GP problem? although it's a local
computer account)
Security Accounts Manager
Windows Driver Foundation - User-mode Driver Framework
Windows Error Reporting Service

The following services seemed to restart on their own once I stopped them:
COM+ Event system
Windows Multimedia Instrumentation
Windows Search
Program Compatibility Assistant Service

So any of the above services could be the culprit or more likely there
might have been some other proprietary service causing the problem. 

The good thing is the solution seemed to be: installing Cygwin and sshd
from Safe mode with networking.

> On that same machine, I tried removing cygwin and reinstalling
> the base packages.  Although you can get a cygwin.bat to run,
> each of the postinstall scripts gives an error when run.  So it
> is not likely that it is a "clean" install.  Has anyone seen these
> kinds of errors in /var/log/setup.log.full ?
> I've tried a host of chmod 777 and chgrp Users and chgrp Administrators
> attempts but always seem to get the bash.exe.stackdump in /
> Could this be a result of using RDP and remote sessions?
> Could it be that it is a dual core AMD?
> I don't have direct access to the computer (2 hours by plane).
> Thanks - Jim
> ===
> 2007/09/05 16:41:02 Starting cygwin install, version 2.573.2.2
> ...
> 2007/09/05 16:42:05 running: C:\cygwin\bin\bash.exe -c
> /etc/postinstall/terminfo.sh
>      16 [unknown (0xC90)] bash 3692 _cygtls::handle_exceptions:
>  227131 [unknown (0xC90)] bash 3692 open_stackdumpfile: Dumping stack
> trace to bash.exe.stackdump
> 2007/09/05 16:42:16 abnormal exit: exit code=35584
> 2007/09/05 16:42:16 running: C:\cygwin\bin\bash.exe -c
> /etc/postinstall/00bash.sh
>       6 [unknown (0xE18)] bash 3680 _cygtls::handle_exceptions:
>  124434 [unknown (0xE18)] bash 3680 open_stackdumpfile: Dumping stack
> trace to bash.exe.stackdump
> 2007/09/05 16:42:22 abnormal exit: exit code=35584
Jeremy K. Truax

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list