1.5.24: sshd immediately disconnects upon receiving a connection

Jim Kleckner jek-cygwin2@kleckner.net
Thu Sep 6 00:32:00 GMT 2007


Jeremy K. Truax wrote:
> So as I said in the last message for this thread, I was able to get sshd
> fully working by uninstalling the antivirus.
>
> In case anyone else is using NOD32 for antivirus (www.eset.com), it has a
> special service called IMON (Internet monitor) that seems to be pretty
> picky on what kinds of sockets can be accepted and it didn't like something
> about the way sshd was generating socket connections so it was blocking
> them. I was able to reinstall the antivirus and simply add exclusions for
> cygrunsrv.exe and sshd.exe in the IMON portion of NOD32.
>
> Now the fun begins....this was all on Windows XP SP2...everything worked.
> Well the laptop was shipped with Vista and not all the drivers could be
> found for XP so we were forced to switch the laptop back to Vista. We had
> previously downgraded to XP thinking that might be part of the
> problem....well we were partially right.
>
> My current issue is that the Cygwin sshd service refuses to stay running
> (similar to before) but manually starting up sshd (like in the past couple
> messages) works correctly and I am able to connect.
>
> Windows firewall and defender are shut off, NOD32 is fully uninstalled at
> this point still. 
>
> The event viewer shows an error log:
>
> Log Name:      Application
> Source:        Application Error
> Date:          9/5/2007 10:18:58 AM
> Event ID:      1000
> Task Category: (100)
> Level:         Error
> Keywords:      Classic
> User:          N/A
> Computer:      AVILA
> Description:
> Faulting application cygrunsrv.exe, version 0.0.0.0, time stamp 0x449671dc,
> faulting module cygwin1.dll, version 1005.24.0.0, time stamp 0x45c06855,
> exception code 0xc0000005, fault offset 0x000de9a1, process id 0xcdc,
> application start time 0x01c7efe0d7a0b98b.
>
>
> Anyone else possibly run into problems running sshd as a service under
> Vista? But it working fine when starting it up manually?
>   

On that same machine, I tried removing cygwin and reinstalling
the base packages.  Although you can get a cygwin.bat to run,
each of the postinstall scripts gives an error when run.  So it
is not likely that it is a "clean" install.  Has anyone seen these
kinds of errors in /var/log/setup.log.full ?

I've tried a host of chmod 777 and chgrp Users and chgrp Administrators
attempts but always seem to get the bash.exe.stackdump in /

Could this be a result of using RDP and remote sessions?
Could it be that it is a dual core AMD?
I don't have direct access to the computer (2 hours by plane).

Thanks - Jim


===
2007/09/05 16:41:02 Starting cygwin install, version 2.573.2.2
...
2007/09/05 16:42:05 running: C:\cygwin\bin\bash.exe -c 
/etc/postinstall/terminfo.sh
     16 [unknown (0xC90)] bash 3692 _cygtls::handle_exceptions: 
Exception: STATUS_ACCESS_VIOLATION
 227131 [unknown (0xC90)] bash 3692 open_stackdumpfile: Dumping stack 
trace to bash.exe.stackdump
2007/09/05 16:42:16 abnormal exit: exit code=35584
2007/09/05 16:42:16 running: C:\cygwin\bin\bash.exe -c 
/etc/postinstall/00bash.sh
      6 [unknown (0xE18)] bash 3680 _cygtls::handle_exceptions: 
Exception: STATUS_ACCESS_VIOLATION
 124434 [unknown (0xE18)] bash 3680 open_stackdumpfile: Dumping stack 
trace to bash.exe.stackdump
2007/09/05 16:42:22 abnormal exit: exit code=35584

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: save.setup.log.full
URL: <http://cygwin.com/pipermail/cygwin/attachments/20070906/88e53dd9/attachment.ksh>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cygcheck.out
URL: <http://cygwin.com/pipermail/cygwin/attachments/20070906/88e53dd9/attachment-0001.ksh>
-------------- next part --------------
--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/


More information about the Cygwin mailing list