Setup Error

ERIC HO ericmho@shaw.ca
Sat Sep 1 15:53:00 GMT 2007


I tried to reinstall the coreutils and cywin and it is getting worse because now many commands like ls, echo, uname, mount and umount cannot be found. I cannot rename/delete the cygwin root folder. Any thing I can do manually to stop it from uninstalling rxvt which causes the setup error or any work around solutions like unzipping the indivually packages? Is my only choice is to delete the registry tree Software\Cygnus Solutions under HKEY_LOCAL_MACHINE and/or HKEY_CURRENT_USER and reboot the machine for me to rename/delete cygwin root folder? It seems drastic. Thanks

----- Original Message -----
From: ERIC HO <ericmho@shaw.ca>
Date: Friday, August 31, 2007 7:14 pm
Subject: Re: Setup Error
To: cygwin@cygwin.com

> I did a gdb on setup and saw the following messages when  
> uninstalling rxvt:
> warning: LOG: 2 Running preremove script for  rxvt
> warning: LOG: 2 Uninstalling rxvt
> 
> Program received signal SIGSEGV, Segmentation fault.
> [Switching to thread 2648.0x1cc]
> 0x004ac7e3 in ?? ()
> 
> Any idea? Thanks.
> 
> 
> ----- Original Message -----
> From: ERIC HO <ericmho@shaw.ca>
> Date: Friday, August 31, 2007 7:34 am
> Subject: Setup Error
> To: cygwin@cygwin.com
> 
> > I'm running snapshot 2007-08-10. When I ran setup to install 
> the 
> > new rxvt, it hang. I then canceled the install. Now everytime 
> I 
> > ran the setup again, it tries to uninstall rxvt. But then 
> setup 
> > encountered an error and closed. It seems some files/registers 
> > corrupted. Is ther anyway to workaround this problem?  
> Any 
> > doc will help? The same problem with snapshot 2007-08-13. I 
> did 
> > try rebooting the machine twice but to no avail. Thanks.

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list