screen reattach not working?

Damjan Lango damjan.lango@gmail.com
Fri Oct 5 12:48:00 GMT 2007


As I see you're requesting cygcheck -s -v -r output for other
problems, I'm attaching it here as well if it helps with my ssh /
screen reattach problem.
btw, when cygcheck completed, it also reported:
'id' program not found
'id' program not found
but id is working fine:
$ id
uid=1000(Damjan) gid=513(None) groups=513(None),544(Administrators),545(Users)
$ type id
id is hashed (/usr/bin/id)


On 2007-10-05, Damjan Lango wrote:
> Another update on my screen adventures, please accept my apologies
> since i'm posting so frequently.
>
> I have removed completely the /tmp/uscreens/S-Damjan directory and
> it's contents and killed all the cygwin processes. Now screen
> reattaching works in CMD cygwin bash window as well (and rxvt and
> xterm)
>
> But still no luck with ssh.
> If I run screen under ssh, then detach it and then try to re-attach
> under ssh nothing happens, screen -r just exits with no message. If I
> try to attach to that screen from a local CMD bash window I get the
> following message:
>
> Suddenly the Dungeon collapses!! - You die...
>
> btw ps -e under ssh and under local cmd window do not show the same
> processes even though id reports the same user. It seems to me that
> there might be some problem with privileges under ssh or something?
>
> what else can I try? :)|
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck.out
Type: application/octet-stream
Size: 17601 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20071005/024ef735/attachment.obj>
-------------- next part --------------
--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/


More information about the Cygwin mailing list