Problems Starting sshd as a service through CYGWIN

Kyle Flavin
Thu Nov 29 22:50:00 GMT 2007

I have changed quite a bit.

Larry Hall (Cygwin) wrote:
> On 11/29/2007, Kyle Flavin wrote:
>> I am having trouble starting sshd as a Window's service.  I've looked 
>> over the mailing list archives, but have been unable to find a 
>> resolution to my problem.  I apologize for the length of this email, 
>> but I tried to include all pertinent information.  I have attached 
>> the output of cygcheck -s -v -r. 
> <snip>
> You sure you're not just suffering from some form of
> <>?
> Of some concern is the fact that you have another installation of some
> like tools including, apparently, 'ssh'.  I don't see these interfering
> based on the information you sent but....
> Also, your attempts to research and solve this problem are admirable and
> commendable but you may have taken it a little too far.  You mentioned 
> that
> you can 'sshd' from the command line, though you don't mention the 
> user you
> are when you run it that way.  If you didn't do this from a SYSTEM-owned
> shell the first time you tried it, you may very well have prohibited
> yourself from getting this to work for you as a service easily.  You may
> want to consider wiping your installation again and reinstalling.  The
> problem is that permissions on some files get set specifically for the
> user running of 'sshd' and running it as another user isn't an 
> option.  Now
> it is possible to run around to all the needed files/directories and 
> reset
> the permissions back to what's needed but that's allot of work and is
> error prone.  Also, given the changes you've tried so far relative to
> granting/restricting certain permissions, this compounds the problem.
> So there are a few things to mull over. ;-)

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list