Perl is installed in /lib, but indicates it is in /usr/local/lib

Thu Nov 29 03:46:00 GMT 2007

It looks like I misspoke slightly.  I reviewed the "" again and it 
thinks it is installed in "/usr/lib". I don't even have a "lib" directory 
under "usr" on a clean install of cygwin.

One of the lines in "" is "archlibexp => 
Also "" has the line 

Just for clarification.  I have a clean install of cygwin with the packages 
necessary to attempt a build of rrdtool.  "rrdtool" is the only software I 
have that did not come from the cygwin setup.  "Perl" and "TCL" can't find 
several functions from the following packages: libartlgpl2, libpng12-devel & 
libfreetype2-devel.  If I only disable "TCL", I get the same "undefined 
reference" errors from "PERL".  The configure script finds the libraries 
with no dificulty and if I attempt a build by disabling "TCL" and "PERL" it 
works.  The only way I can get "PERL" to be included is by using the option 
"LINKTYPE=static", but I'm not sure of the consequences of that action.

Some of the errors are "undefined reference to `_art_vpath_add_point'", 
"undefined reference to `_FT_Done_Glyph'" & "undefined reference to 

I tried copying the contents of the "/lib" directory to "/usr/lib" and 
"/usr/local/lib" as an attempted workaround.  This however did not solve the 
problem.  Even if this is a problem with "rrdtool", it doesn't explain the 
"" and "" files.

If I am wrong and this is a problem with "rrdtool", please let me know and I 
will address it with them instead.  I did try this with the latest version 
1.2.26 and an older version 1.2.15 with the same results.

Attached is the output of the perl command line Robert sent.

I wish cygwin would use forums instead of a mailing list.


----- Original Message ----- 
From: "Robert Kiesling" <>
To: <>
Sent: Wednesday, November 28, 2007 7:15 PM
Subject: Re: Perl is installed in /lib, but indicates it is in 

>[ Charset UTF-8 unsupported, converting... ]
>> Etienne wrote:
>> > I have been trying to build rrdtool and as I watched it run I noticed a
>> > problem with Perl and TCL./TK.  Both indicated that they were installed
>> > in /usr/local/lib.  I tried a clean install of cygwin, but it still
>> > installed them into /lib.  I checked and it still indicates
>> > that it is in /usr/local/lib.  Why is there a discrepancy?
>> >
>> > I am running the latest version of cygwin
>> Neither the Cygwin TCL/TK nor the Cygwin Perl package install anything in
>> /usr/local.  See:
>> <>
>> <>
>> Perhaps looking at the output of 'cygcheck -s -r -v' would help you
>> find the errant installations?
> What is the output of Config?
> Here is a (long) one-liner to print the configuration lib paths
> (and everything else).
> perl -e 'use Config; foreach (keys Config) {print "$_\t$Config{$_}";}'
> Regards
> -- 
> Ctalk Home Page:
> --
> Unsubscribe info:
> Problem reports:
> Documentation:
> FAQ:         
-------------- next part --------------
A non-text attachment was scrubbed...
Name: perlconfig.tsv
Type: application/octet-stream
Size: 20098 bytes
Desc: not available
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list