file permission problem

Larry Hall (Cygwin) reply-to-list-only-lh@cygwin.com
Wed Nov 28 01:07:00 GMT 2007


Win Tong wrote:
> Hi,
> 
> I have a difficult problem which I don't know how to solve and I'll
> appreciate any help.
> I'm using windows XP Home with cygwin and I want to remove the directory
> 'no_bulk' and all the files within it.
> 
> The following commands show me something like this
> 
> $ rm -r no_bulk
> rm: cannot remove `no_bulk/con': No such file or directory
> 
> $ ls -l no_bulk
> ls: no_bulk/con: No such file or directory
> total 0
> ---------- 0 ???????? ???????? 0 Jan  1  1970 con
> 
> I tried to delete it through windows explorer as a administrator but it
> say cannot find the specified file even though it shows the file and say
> the file has 71kB and modified on 15/09/2007.
> 
> I've search google but cannot find anything that helps.
> This is not the only directory that has this wired file and I want to
> get rid of them.
> please help

'con' is a reserved Windows file name.  You must have worked pretty hard
to create it since you can't create it by normal means.  Anyway, you can
get rid of it using the '//?/<fully qualified path>' syntax.  For
example:

bash-3.2$ mkdir foo
bash-3.2$ cd foo
/cygdrive/f/foo
bash-3.2$ touch '//?/f:/foo/con'
bash-3.2$ ls -l
ls: con: No such file or directory
total 0
---------- 0 ???????? ???????? 0 Dec 31  1969 con
bash-3.2$ rm '//?/f:/foo/con'
bash-3.2$ ls -l
total 0

-- 
Larry Hall                              http://www.rfk.com
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
216 Dalton Rd.                          (508) 893-9889 - FAX
Holliston, MA 01746

_____________________________________________________________________

A: Yes.
 > Q: Are you sure?
 >> A: Because it reverses the logical flow of conversation.
 >>> Q: Why is top posting annoying in email?

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list