Library Problem
Fri Nov 23 01:36:00 GMT 2007


I've got a problem using the libflv library ( The build worked without any problems. "make" produced a file, so i copied it as "libflv.dll" to "/usr/lib". I wrote a test app and tried building it with:
"gcc -lflv test.c -o test.exe"
That worked well (no warnings,errors). 
But if I try running "./test.exe" there's no responce at all and I get the bash prompt again. 

user@cygwin ~
$ ./test.exe

user@cygwin ~

When I remove the libflv functions I get the "printf" output...
The same code works well on unix systems... 
Probably a linking error? How can I fix that? 

Thanks in advance! 


#include <libflv.h>
#include <stdio.h>

int main( void ){
  Stream *vstream;
  FlvStream *flv;
  int width = 400;
  int height = 300;

  srand ( time(NULL) );
  vstream = ScreenVideo_newStream(width, height, 16, 9);
  flv = FlvStream_newStream("./out.flv", NULL, vstream , FLV_VERSION_1);

Der GMX SmartSurfer hilft bis zu 70% Ihrer Onlinekosten zu sparen! 
Ideal für Modem und ISDN:

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list