syslog-ng-config errors

Tony Benham
Tue Nov 13 10:28:00 GMT 2007

Corinna Vinschen <corinna-cygwin <at>> writes:

> On Nov 12 18:22, Tony Benham wrote:
> > I've decided to run syslog-ng on my cygwin installation. I updated to latest
> > version When I run syslog-ng-config I get four errors 
> > setfacl : illegal acl entries
> > 
> > Is this to be expected ?
> All four setfacl calls try to add the SYSTEM user to file/directory ACLs.
> If that doesn't work, the SYSTEM user doesn't exist in your /etc/passwd
> file, apparently.  If so, your /etc/passwd is broken.  You should fix it
> by rerunning mkpasswd.

I ran mkpasswd -d domain >> /etc/passwd to recreate passwd. But the problem
remains. I cannot see the SYSTEM user in the file. Is there a switch for
mkpasswd I need to use ? This machine is also a W2003 DC will that make a
difference ?

> Corinna
I will look at your other suggestions when I can resolve the first problem.

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list