xargs: cannot fork: Resource temporarily unavailable

Jose Correia jose.correia@traderoot.com
Mon Nov 12 14:37:00 GMT 2007

Hi all
Im using cygin install when the cygwin install version 2.457.2.2 on
Windows XP professional SP2, on an IBM ThinkPad Dual Processor T60.
I run a unix script from a bigger ant script, which used to work fine on
a single processor laptop. Now it works intermittently 
The Unix script is this:
export SRC=$1
find $SRC -type d -name 'CVS' | xargs -i rm -rf {}
mv $SRC/tres/src/java/com/traderoot/core/
#for jaxb generated source
mv $SRC/com/traderoot/core/ $SRC/com/traderoot/cfgcore
grep -Rl  'com.traderoot.core' $SRC | xargs -i ./replace.sh
's/com\.traderoot\.core/com.traderoot.cfgcore/g' {} 
grep -Rl  'com/traderoot/core' $SRC | xargs -i ./replace.sh
's#com/traderoot/core#com/traderoot/cfgcore#g' {}
grep -Rl  'com.traderoot.tools' $SRC | xargs -i ./replace.sh
's/com\.traderoot\.tools/com.traderoot.cfgtools/g' {}
On the times when it does not work it spews out:
[exec] + xargs -i ./replace.sh
's/com\.traderoot\.tools/com.traderoot.cfgtools/g' '{}'
     [exec] replacing in
     [exec] replacing in
     [exec] replacing in
     [exec] replacing in
     [exec]       4 [main] xargs 112660 fork_copy: linked dll data/bss
pass 0 failed, 0x54D000..0x54D020, done 0, windows pid 114584, Win32
error 487
     [exec] xargs: cannot fork: Resource temporarily unavailable
Could this be because of the dual processor where somehow the one
process is left hanging waiting for the other? Anyone experienced this
issue before...? can't find anything on the archives...
Jose Correia

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list