Version mismatch - gcov and -mno-cygwin

Jevin Sweval jevinsweval@gmail.com
Fri Nov 9 22:23:00 GMT 2007


When adding instrumenting to -mno-cygwin compiled programs (using
-ftest-coverage -fprofile-arcs and linking against -lgcov), I get and
error complaining about "version mismatch between version 304c and
304m". Using `strings`, I believe that the gcc versions (for the
cygwin and mingw cc1) are 304c and that libgcov is version 304m. Is
there any chance that the package could be fixed? If not, any advice
on what to do to fix the problem? Thanks!

-Jevin Sweval

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list