1.5.24 -2 cygwin python 2.5.1 problem, "import sqlite3" fail

Christopher Faylor cgf-use-the-mailinglist-please@cygwin.com
Mon Nov 5 23:47:00 GMT 2007


On Mon, Nov 05, 2007 at 03:07:57PM -0800, Brian Dessent wrote:
>Thorsten Kampe wrote:
>>As far as I understood Jason, he just needs the SQLite headers and
>>libraries to /build/ Python with SQLite support, and he doesn't need
>>them to be "in Cygwin".
>
>That would be silly, because it would result in a totally broken python
>that would continue to throw ImportError on "import sqlite3" because
>the user would have no cygsqlite3-0.dll on their system, with no way to
>get it unless they installed third party packages that aren't part of
>Cygwin.  Besides, requiring packages not in the distro in order to
>build a package is not kosher.  The distro must be self-consistent.

Yes.  What he said.  Jason understands what it means to add this support.
Thorsten does not.  Unless someone wants to support SQLite3 (which would
be a welcome addition to Cygwin), I think this thread has gone on for
about six messages longer than it should have.

cgf

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list