Problem with finding mirror lists using setup.exe

James Sherman Jr.
Wed May 30 23:11:00 GMT 2007

"Brian Dessent" wrote:

> You should of course try a development snapshot of setup
> <> but I can't think of anything that
> would have changed in this area.  You can also try putting a copy of the
> mirrors.lst file as /etc/setup/mirrors-lst and setup would then use this
> cached copy of the list.  But as to why it can't fetch the URL itself, I
> have no idea.  It could be some quirk of your networking setup.

So I took the mirrors.lst file and placed it in
d:\cygwin\etc\setup\mirrors-lst (since I set my root directory to be
d:\cygwin) and I still got the same error about not finding the list of
download sites.  For some reason I guess it wasn't checking the cache?

Next, I downloaded the snapshot 2.572.  I blew away the mirrors-lst file to
see if it would be successful in finding the mirror list.  When it searched
for the list, it didn't come across an error (like before) but came up with
just a blank list.  I then tried to enter a user mirror from the mirror.lst
file in the entry box at the bottom (I tried then I got an error saying that it was:
"Unable to get setup.ini from <>"
I tried a couple other mirrors and got the same error.  Furthermore, when I
manually put the mirrors.lst file in d:\cygwin\etc\setup\mirrors-lst, the
mirrors list was populated correctly with the 2.572 version. Same error
about setup.ini still occurs though.

Thanks again for your quick responses.  I don't have time tonight, but I'll
try the other workarounds you suggested tomorrow.

-James Sherman

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list