password authentication fails in cygwin openssh windows xp pro

René Berber
Thu May 24 08:10:00 GMT 2007

Dan Miller wrote:

> C:\Program Files\UVP
> Inc\;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;C:\Program
> Files\ATI Technologies\ATI Control Panel;C:\Program Files\Common
> Files\GTK\2.0\bin;C:\Program Files\Zone
> Labs\ZoneAlarm\MailFrontier;C:\cygwin\bin
Warning Will Robinson, ZoneAlarm could cause problems; also the GTK stuff which
does have some common dlls with Cygwin but compiled for MingW... but from your
report none of this seems to be causing the problem.

> I created an environment variable named CYGWIN and set its value to
> ntsec tty

Not needed.

> ran ssh-host-config and answered yes to all questions including
> privilege separation
> When asked for the value of CYGWIN I again typed ntsec tty

Again, not needed (those are the defaults).

> At this point I can start the sshd service (cygrunsrv -S sshd) but if I
> try to login (ssh localhost) I get a password prompt and it fails.

How it fails?

Have you tried `ssh -vvv localhost`?

Do the /etc/passwd and /etc/group files exist? and is your user in the first one?

> So, I made a new user named sshdproc, gave it the administrators
> password, and put it in the administrators group and gave it the
> following rights:
> now I can start the sshd service, it runs as sshdproc, but still when I
> ssh localhost I get prompted and my password fails

You didn't solve the first problem and just went looking for more?

> so I ssh-user-config
> still no joy.....
> Can someone please give me some advice on where to go from here. I don't
> know what else to try and I don't know how to troubleshoot why my
> password is failing to authenticate.

Just to make sure, the server does ask for the password 3 times? and it rejects
it (look in the Windows events, if you are not using syslog, sshd leaves a
message saying it rejected an invalid password, or invalid user).

Your user is local, not a domain user, right?

Post the result of the `ssh -vvv your-user@localhost`, it may show the problem
in detail.
René Berber

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list