su: cannot set groups: Invalid argument

Christopher Faylor
Thu May 10 22:25:00 GMT 2007

On Thu, May 10, 2007 at 10:48:55AM -0700, Ben Atkin wrote:
>I've been using the standard cygwin distribution for setting up
>ssh/sftp on Windows Server 2003. It's been working fine for the
>Administrator account, but now I'd like to set up another account and
>use that, just in case people see ssh running on a windows computer
>and try running a password guesser on the Administrator account.
>There is a domain account that I'd like to use. I can get to it if I
>ssh into the domain controller, but it won't work for other computers
>on the domain. I searched for a solution, and I found mkpasswd. I ran
>"mkpasswd -d (domain) -u (user)" and it worked without error and so I
>appended the entry to /etc/passwd.
>To test it, I tried doing "su (username)". It prompts me for the
>password, and after I enter the password, it says "su: cannot set
>groups: Invalid argument". Does anyone have any idea why this error
>might occur? I searched for my error message to no avail.


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list