can not exec cc1.exe

Jim Marshall
Wed May 9 22:56:00 GMT 2007

  I've been using cygwin for a while now, we have been using the make 
along with MS C compiler (cl.exe) and it has worked extremely well. 
Recently we decided to switch to use gcc for some projects and it works 
great, but we wanted to make executables that did not require 
cygwin1.dll. As such we installed the mingw cygwin packages, but when we 
use the "-mno-cygwin" option I get an error that it can not exec cc1.exe

$ cc -mno-cygwin main.c
cc: installation problem, cannot exec 'cc1': No such file or directory

I have tried uninstalling and reinstalling the mingw packages with no 
luck. The links "appear" ok in the mingw directory:

$ ls
bin.lnk*  include.lnk*  lib.lnk*

But I'm not sure how to verify that they are valid.

Just to be clear, using gcc works fine it only fails with the 
"-mno-cygwin" option.

The machine I am on is a Windows XP Pro with SP2, with gig of RAM. It's 
a core duo 1.6GHz.

Hope I have provided enough information, if not let me know.

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: a.txt
URL: <>
-------------- next part --------------
Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list