Cygwin Problems on Vista (Install and others)

Morgan Gangwere
Fri May 4 12:22:00 GMT 2007

On 5/3/07, N Y <thisrabbit(munumana)> wrote:
> I've read that some people can get Cygwin to run on Vista without
> problems, but I've run into almost every reported problem.
> I've trying to install Cygwin on my new Dell laptop for two days now.
> Intel Centrino Duo with Vista Ultimate.  I'm installing for all users,
> unix mode.  From category view, I'm installing all groups except for
> audio, databases, games, and publishing.  I have the 2.510.2.2
> setup.exe.  The installed cygwin1.dll is 1.5.24-cr-0x5f1.
> First problem: hang on
> I tried everything: run as administrator, setting the compatibility mode,
> set the Windows PATH to include "C:\cygwin\bin" before running
> setup.exe (via cmd shell), disabling UAC - nothing worked.
> Finally I opened Task Manager and manually killed the bash process.
> That kicked setup to continue.  Eventually I re-ran manually,
> once I got bash running happily.
> Second problem:
> When I started the cygwin shell (via the desktop shortcut), I got this message
> "Your group is currently "mkpasswd". This indicates that
> the /etc/passwd (and possibly /etc/group) files should be rebuilt.
> See the man pages for mkpasswd and mkgroup then, for example, run
> mkpasswd -l [-d] > /etc/passwd
> mkgroup  -l [-d] > /etc/group
> Note that the -d switch is necessary for domain users."
> So I ran mkpaswd and mkgroup and that problem went away.

this isnt really a problem. its just cygwin wanting a /etc/passwd and
/etc/group that it likes, but they didnt get generated because of a
phase of the moon bug. (i get it with the user "admin" but not with
the user "user" - both exist on my machine)

> Third problem:
> Then I tried to click the startx shortcut on the desktop.  The xserver starts
> but the xterm that comes with it never appears.  I tried startx from the cygwin
> bash shell.  Sometimes it starts and an xterm appears.  and sometimes it
>  exits right away.  I closed all cygwin apps and ran ash from cmd.exe,
> ran rebaseall.  Now the startx works from the cygwin bash shell.

erm... the startx shortcut is _supposed_ to do that. you can run this
at a cygwin terminal or from a batch file for a child X window root
and twm:
X -display localhost:0 (blah) & (NOTE the "&" and YES it has to be
localhost. no 's - Hast Worked For Me.)
twm -display localhost:0 & (again, note the "&")

> Fourth problem:
> I wanted to quickly test my access to a remote system via rsh.
> I open a cygwin bash shell and run "rsh user1@foo ls" and get back:
> "12673 [main] rsh 4060 C:\cygwin\bin\rsh.exe: *** fatal error - couldn't dynami
> cally determine load address for 'rcmd' (handle 0x74140000), Win32 error 127
> Hangup"

i dont do rsh but have you tried this from another computer (with say
PuTTY) - also, see if rsh's daemon is alive or if you need one.. i
install everything and usually I dont get a real rsh daemon, so i
compile the official one from source.

> If anyone has any suggestions I'd love to hear it.
> N
> --
> Unsubscribe info:
> Problem reports:
> Documentation:
> FAQ:         

Morgan gangwere

"Space does not reflect society, it expresses it." -- Castells, M.,
Space of Flows, Space of Places: Materials for a Theory of Urbanism in
the Information Age, in The Cybercities Reader, S. Graham, Editor.
2004, Routledge: London. p. 82-93.

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list