rsync hang

Frank Fesevur
Fri May 4 08:04:00 GMT 2007

Scott T. Marshall wrote:
> I have been having some errors when using rsync to copy files from a 
> remote cygwin machine to my local cygwin machine. I read posts the 
> cygwin web forum. I have the same hang problem in that when I try to 
> rsync (get) files from a remote machine rsync just hangs if any 
> directory has what seems to be >100 files. Is there any fix for this 
> yet? The posts I saw were from April of 2006, so I don't know if the 
> problem is now solved or not.

No, unfortunately this problem is not solved. But the problem is not in 
rsync itself, but in the cygwin1.dll. See

I have looked at that code, but it is quite difficult stuff. And I'm 
having trouble compiling the cygwin.dll (downloaded the 1.5.24-2 sources 
via setup.exe), so I can't even give it a try at this moment. Although 
it is not the real compilation, but generating the docs :-S

But a lot of people have this problem. It becomes a FAQ.


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list