Cygwin Problems on Vista (Install and others)

Fri May 4 02:21:00 GMT 2007

I've read that some people can get Cygwin to run on Vista without
problems, but I've run into almost every reported problem.

I've trying to install Cygwin on my new Dell laptop for two days now.
Intel Centrino Duo with Vista Ultimate.  I'm installing for all users,
unix mode.  From category view, I'm installing all groups except for
audio, databases, games, and publishing.  I have the 2.510.2.2
setup.exe.  The installed cygwin1.dll is 1.5.24-cr-0x5f1.

First problem: hang on
I tried everything: run as administrator, setting the compatibility mode,
set the Windows PATH to include "C:\cygwin\bin" before running
setup.exe (via cmd shell), disabling UAC - nothing worked.
Finally I opened Task Manager and manually killed the bash process.
That kicked setup to continue.  Eventually I re-ran manually,
once I got bash running happily.

Second problem:
When I started the cygwin shell (via the desktop shortcut), I got this message

"Your group is currently "mkpasswd". This indicates that
the /etc/passwd (and possibly /etc/group) files should be rebuilt.
See the man pages for mkpasswd and mkgroup then, for example, run
mkpasswd -l [-d] > /etc/passwd
mkgroup  -l [-d] > /etc/group
Note that the -d switch is necessary for domain users."

So I ran mkpaswd and mkgroup and that problem went away.

Third problem:
Then I tried to click the startx shortcut on the desktop.  The xserver starts
but the xterm that comes with it never appears.  I tried startx from the cygwin
bash shell.  Sometimes it starts and an xterm appears.  and sometimes it
 exits right away.  I closed all cygwin apps and ran ash from cmd.exe,
ran rebaseall.  Now the startx works from the cygwin bash shell.

Fourth problem:
I wanted to quickly test my access to a remote system via rsh.
I open a cygwin bash shell and run "rsh user1@foo ls" and get back:
"12673 [main] rsh 4060 C:\cygwin\bin\rsh.exe: *** fatal error - couldn't dynami
cally determine load address for 'rcmd' (handle 0x74140000), Win32 error 127

No solution to this problem yet.

If anyone has any suggestions I'd love to hear it.


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list