OpenSSH on Windows XP SP2 problems

Michael Grubb
Fri Jul 20 15:24:00 GMT 2007

I'm about at wits end on this one I can't seem to figure out what's  
going on.
I've had the openssh server running on the same version of windows  
(Windows XP Pro SP2 fully patched) for quite some time.
The first time I installed it using the instructions at http:// which worked beautifully.
This time however, I'm having issues.  After following the  
instructions I was first presented with issues dealing with the  
privilege separation feature.
I've got those worked out and now have a more serious trouble that  
I'm not sure where to proceed from here.
Now, when I try to start the sshd daemon (using debug mode) I get the  
following message:

debug1: sshd version OpenSSH_4.6p1
debug1: read PEM private key done: type RSA
debug1: private host key: #0 type 1 RSA
debug1: read PEM private key done: type DSA
debug1: private host key: #1 type 2 DSA
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-D'
debug1: rexec_argv[2]='-d'
debug1: Bind to port 22 on
Bind to port 22 on failed: Bad address.
Cannot bind any address.

I've tried explicitly adding my IP address with the ListenAddress  
directive in the /etc/sshd_config file.  I've tried altering the port  
number to a non-privileged port.
I can't seem to get anything to work.  I'm running the latest version  
of cygwin from

I did download another project OpenSSH for windows, which seems to be  
based off cygwin. It used an older version of openssh as well as the  
cygwin DLL, I believe, as they didn't really like having each other  
installed at the same time.  However, the OpenSSH for windows worked  
as far as getting the service to load and accept connections.  So I'm  
not sure where the root cause of the problem lies in this case.  Is  
it a bug in this version of OpenSSH (doubtful because I've been  
running a similar or same version for months before I reloaded)?  Is  
it an OS permissions problem (not sure, as I'm a UNIX geek and don't  
know windows internals very well)?  Is it a cygwin DLL bug(I'd expect  
to have found more information on this, if that were the case)?

Any help is greatly appreciated.

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list