fopens fails to open binary files on Vista

Kirk Russell
Tue Jul 10 19:52:00 GMT 2007

I am running Windows Vista and I have written a program on cygwin that opens a binary file using the fopen call with a mode of "rb". At run time I receive the following error message:
Invalid Parameter passed to C runtime function.
If I were to remove the "b" in "rb", the library call is successful. Is there a different way to open binary files when running an executable on cygwin, on Vista.
I also tried to use the setmode call and it failed as well with the same error.
Here is how I am building my executable. I would appreciate any help or information you could give me. 
gcc -DHAVE_CONFIG_H -I. -I/home/krussell//usr/win32/include  -I. -I /usr/include
 /usr/local/ssl/lib/libcrypto.a -g -O2 -Wall -W -MT secureDisk.o -MD -MP -MF "se
cureDisk.Tpo" -o secureDisk -mno-cygwin secureDisk.c /usr/local/ssl/lib/libcrypt
o.a ; \

Kirk Russell
864 242 5100 x3884 

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list