vista rsh problem

Mon Jul 9 19:43:00 GMT 2007

goetz fischer wrote:
> Corinna Vinschen wrote:
>> On Jul  9 19:10, goetz fischer wrote:
>>> i have vista with cygwin (current snap) and the command 'rsh
>>> <server_ip>' causes the prompt to hang forever.
>>> it works with cygwin on xp so it should be a vista issue.
>>> i posted the server info already some days ago as well as the
>>> cygcheck output.
>> You're telling that you tested this on XP for the first time now.
> well i used the rsh server with about 8 different platforms and it
> worked with all but vista/cygwin.
>>   You didn't mentioned the server OS anywhere in this thread.
> i did. look again.

In the interests of preventing this thread degenerating further, I've
looked. Can you please point to the message in the archives? *

You've only stated that the server is non-cygwin, not linux, and implied
that it is a 'real' unix box. You have stated that rsh is running on vista.

>>   We only know
>> it's not Cygwin and it's not Linux but some sort of "real" unix(*) which
>> apparently doesn't use PAM.  You didn't tell if you tried anything to
>> diagnose the problem further.
> i did. i've send the cygcheck output with my first mail.

The first mail did indeed have cygcheck output. But you have not been
particularly forthcoming about the server OS, or about what you have
done to try and diagnose the problem...

>>   You did not mention if you ever tested it
>> in other scenarios, like a Cygwin -> Linux or a Cygwin -> Cygwin
>> connection or between XP->Vista and Vista->XP, etc.
> well as i wrote the server is always the same and it worked with
> whatever i tried except vista/cygwin

You say you tested 'about 8 different platforms'. Can you clarify
exactly which? For all we know you've tested cygwin/95, cygwin/98,
cygwin/NT, cygwin/ME, cygwin/XP Home cygwin/XP Professional,
cygwin/2000, cygwin/vista. I suspect you mean that you've 'tested' the
server with a few non-cygwin rsh's as well.

Can you test with a different server?

>>   You didn't reply to
>> Dave's question about any specific software on the Vista machine.
> yes, i did.

Can you please point to the message in the archives? *

>> There's just the bare fact "it hangs in this one instance".  Do you
>> really think a bug report is useful with all that guesswork left?
> see above.
> not my fault if you missed so much.

You're not doing yourself any favors here. Please just (re)state the
information you're being asked for.

>> Apart from that, I have only Cygwin and Linux ready for testing and
>> debugging.  If you use any other OS, you will have to debug this problem
>> by yourself.
> okay, how?
> i don't get any kind of output at all

Verify you are running the rsh you think you are with 'which rsh'.
You could strace the command and look for problems. 'strace rsh <args>'
Are there logs to look at? Can logging be enabled? Both on server and
Test against a cygwin or Linux server to verify that it is not a
particular setting on your vista box. If the problem still manifests and
you can provide enough information on your setup, Corinna may be to do
something to replicate the problem.

May I suggest you reread the thread as preserved in the archives*. That
is what the list has seen, and it appears we have less information than
what you think you have provided.

Even if the information is all there, I think it is still worth
summarizing it all in a single email.


* This thread can be found in the archive at

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list