still having problem: devenv through sshd

Derek Lei Liu
Wed Dec 19 10:22:00 GMT 2007


Kind of wondering if this thing ever work for anyone. A few weeks back, i 
had problem to run "devenv" build script through sshd on windows 2003 
server. here is the thread: The symptom was 
basically the same script can be executed from remote desktop console, but 
not through ssh session. the script simplely hang and doesn't spill out any 
error message. I struggled a lot with it and finally gave up even with 
Dave's help. I then give up 2003 and moved to XP. The problem with XP is 
even more subtle now. I can ssh in with password authentication and execute 
the script just fine (one step closer compare to 2003). However, public key 
authentication still not working (i am getting the fatal error C1902: 
Program database manager mismatch; please check your installation). There 
was a thread discussed this issue so i thought the problem can be worked 
around by just using password authentication. Since i need passwordless 
login process, i employeed perl Net-SCP-Expect and Net-SSH. Both module 
works just fine and are using password authentication (that's what they are 
designed for). However, remotely executing the build script still give me 
C1902 errors. I just can't figure out what's the difference between password 
login interactively and using perl modules. I am stuck again, need some help 
here. Thanks.


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list