Ping failure under Vista 64 SP1 rc1

Ian Puleston
Mon Dec 17 04:44:00 GMT 2007

> Corinna wrote:
>On Dec 14 21:02, Ian Puleston wrote:
>> Hi,
>> I'm running Vista 64 with Cygwin and, now that they finally have 64-bit
>> support for it, MinGW msys. I just installed the new Vista SP1 rc1, and
>> Cygwin ping does not work:
>MingW ping?!?  I didn't know a MingW ping exists.  Are you talking
>about the native Windows ping, maybe?

Yep, I hadn't realized it but ping under MinGW is running the Windows one.

>> Cygwin ftp. I turned off Windows firewall just in case that was having an
>> effect, but that made no difference.
>> I'm using bash 3.2.25 and ping 1.0-1. And ideas?
>Cygwin's ping uses raw socket io, which is restricted to administrative
>users since Windows XP.  Are you running under an admin account?

Yes it's an administrative user account. I'm 99.9% sure that Cygwin ping has
worked fine from that account up to now (now being when I installed Vista
SP1). But based on your comment I just tried opening a Cygwin bash window
using "Run as administrator" and from that window ping works OK.
>Use the native Windows ping.  It's using a special API for the ping
>functionality instead of trying to use raw sockets directly.

Yep, that I can easily do. Thanks.


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list