Why mix DOS files and UNIX files at Set-Up?

ariga masahiro ariga@link-lab.co.jp
Mon Apr 16 02:52:00 GMT 2007

cygwin Seniors,
 Although,I sent the same content mail to eCos mailing-list,
I do not know this is cygwin'problem or eCos's problem,
so I sent the same content to two mailing-lists.
 I am in a predicament!!

 I am a new-comer in eCos environment,working in a Japanese
developing Co.
 My PC is Windows XP machine and I installed cygwin(Setup.exe version 
 selected checkboxs "All Users"(defaut),"Unix"(default).
I also installed the latest eCos configtool from ecoscentric.com.
 I studied ecos hard,I went through hell,
and finally I thought understand how to use eCos configtool.

I ported eCos to my company's original board using SE77x9 template.
I have been in the swing,beginning to enjoy configuring options.
Then suddenly,believe me,really suddenly,when I started cygwin,
next horrifying errors appeared.

bash: $'\r': command not found
': not a valid identifierITORY
bash: $'\r': command not found
': not a valid identifier
bash: $'\r': command not found
': not a valid identifier

Fearfully I started configtool.exe,then
among desert of white canvas of configtool'window frame,
in small letters,
"The root node for all configurable items"
then nothing happened.
My face became as white as configtool's window.

I also noticed when I tried next command on shell,
$ sh-elf-gcc -v
then appeared next error.
bash: $'\r': command not found

I tried re-installation from cygwin three times,
though one installation took me 3 hours !
But ended up the same result.

I finally found why appeared,
bash: $'\r': command not found.
Althoug,when I "set-up"ed cygwin I chose Unix format,
line's last codes of some installed files converted to DOS format('\r\l').

I tried next command in order to convert DOS format to UNIX format.
d2u /etc/profile
then,did not appeare shell command entering error message.

I also tried,
d2u /opt/ecos/ecosenv.sh
then,did not appeare first-said errors when I started cygwin.

Hopefully I entered
$ configtool.exe
"The root node for all configurable items"

I examined some files under cygwin directory,
and found out there mixed tow file formats.

I want to know where I went wrong.
How should I do it.
Please help me.

Please,cgwin Seniors,help me,and enlighten me.

mariga koigakubo

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list