cp command fails when copying from a network drive

Eric Blake ebb9@byu.net
Tue Apr 10 13:22:00 GMT 2007


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

According to Manish Rathi on 4/6/2007 3:42 PM:
> This issue was discussed on the mailing list, and the problem was identified
> related to random values being returned for 'ls -I', and
> FILE_PERSISTENT_ACLS being TRUE/FALSE. Corinna had talked about adding a fix
> for this as well.
> 
> My question: is there a way to get a working version of 'cp'.

Wrong question.  cp works, but only if cygwin1.dll works.  So the better
question is how to get a working version of the cygwin dll.

> I updated to
> the latest 'current' version of cygwin, where cygwin1.dll seems to be built
> on Jan 31, 2007 - but that doesn't seem to have the fix.

Are you willing to try the latest snapshot?  If it correctly works around
your buggy filesystem, let us know (so we need not worry any longer); if
it still fails, then Corinna still has some more investigation to do to
see if she can help you with your buggy filesystem.
http://cygwin.com/faq/faq-nochunks.html#faq.setup.snapshots

- --
Don't work too hard, make some time for fun as well!

Eric Blake             ebb9@byu.net
volunteer cygwin coreutils maintainer
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (Cygwin)
Comment: Public key at home.comcast.net/~ericblake/eblake.gpg
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFGG4+h84KuGfSFAYARAr6aAKCbpsTe3hYPeNIqbH9RzQyjceugSgCfaZVX
wgqxOvBryLEC7nNoUfmNNlM=
=Sqay
-----END PGP SIGNATURE-----

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list