completion-ignore-case problem with cygwin

Levy, Bruce
Thu Sep 14 22:40:00 GMT 2006

Hi Igor,

Thank you very much for your reply.

I invoked 'bash -vx --login -i' and watched the commands that were being
executed.  I did NOT see any reference to completion-ignore-case.
Should I see the lines in .inputrc being executed?  I did not see any
.inputrc output.

From my bash shell I ran bind 'set completion-ignore-case on' and that
worked perfectly.  I then tried putting that line into .bashrc and that
also worked.  So, I have a workaround, but I'm not sure why .inputrc is
not invoked.

Anyway, I sure appreciate your help.

Best Wishes,

-----Original Message-----
From: Igor Peshansky [] 
Sent: Thursday, September 14, 2006 2:41 PM
To: Levy, Bruce
Subject: Re: completion-ignore-case problem with cygwin

On Thu, 14 Sep 2006, Bruce Levy wrote:

> Hi,
> I am using version 1.5.21-2 of cygwin with version 5.1-5 of readline.
> I have the following lines in ~/.inputrc:
> set completion-ignore-case on
> set show-all-if-ambiguous on
> set bell-style none
> # to show all characters
> set meta-flag on
> set input-meta on
> set convert-meta off
> set output-meta on
> and ~/.bashrc contains the following line:
> shopt -s nocaseglob
> In my home directory, I have a directory called Saved.  I type s<TAB>
> (lower case s followed by the TAB character), but I do NOT get any
> filename completion.
>  If I type S<TAB> (upper case S followed bgy the TAB character), I do
> get filename completion.
> It seems that even though I have set completion-ignore-case on, it
> remains off.
> I enter the following command:
> $ bind -V | grep completion
> completion-ignore-case is set to `off'
> disable-completion is set to `off'
> page-completions is set to `on'
> print-completions-horizontally is set to `off'
> completion-query-items is set to `100'
> Please notice that completion-ignore-case is set to off!  I can
> the following commands that seems to prove that I am unable to turn on
> completion-ignore-case.

Yes, it definitely seems to be turned off.  Are you sure your ~/.inputrc
gets read?  Is your HOME variable set correctly?

> $ set completion-ignore-case on

This will not do what you expect.  You want

bind 'set completion-ignore-case on'

> $ bind -v | grep ignore-case
> set completion-ignore-case off
> Why am I unable to set completion-ignore-case?  What am I doing wrong?

Try running 'bash -vx --login -i' to see what commands are executed when
you run a login shell.  Perhaps there is a startup script somewhere that
executes the bind command to turn completion-ignore-case off.
      |\      _,,,---,,_ |
ZZZzz /,`.-'`'    -.  ;-;;,_		Igor Peshansky, Ph.D. (name
     |,4-  ) )-,_. ,\ (  `'-'		old name: Igor Pechtchanski
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"Las! je suis sot... -Mais non, tu ne l'es pas, puisque tu t'en rends
"But no -- you are no fool; you call yourself a fool, there's proof
enough in
that!" -- Rostand, "Cyrano de Bergerac"

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list