problem running a UDP client and server

Varun Sharma
Mon Jun 26 12:18:00 GMT 2006

 I have been trying to run the abing code
( It basically set up a
UDP client and server and then there are excahnge of UDP packets. I have
been running into troubles since when I have been trying to install it.
 Firstly the make file had the -lnsl option which it cannot find in
cygwin, so I removed it and compiled the code and everything worked fine
with the warning that it cannot find the -pthread option.
 Then to run the reflector in abing, one has to execute the following
./abw_rfl -c &
./abing -c
./abw_rfl &

But in my case, I get an error when I run ./abing -c saying that revcfrom
failed with invalid argument. The code works fine with no error at all in
a normal linux distro. I am unable to find out the difference. Even UDP
clients and server codes which can be easily downloaded from the net work
 I would be really obliged if someone can tell me the problem or some
ekind of an experience he or she has on installing and using abing on

Thanks a lot in advance.
Varun Sharma

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list