Pb with bash script under cygwin

ydubost yann.dubost@capgemini.com
Mon Jun 19 13:50:00 GMT 2006

Thanks Dave for your answer.
I tried 
and directly 
      find . ${Extension} -exec rm {} \; -print 

but none of them worked, I then tried just a 
      find . -name *._cn" -print  that should have sent me back some results
but did not!
So thanks to you idea of executing bash -x, I looked at what's happening and
the result is that the command executed is :
      find . -name '"*._SN"' -o -name '"*._sn"' -o -name '"*._lg"' -o -name
'"*.LG"' -exec rm '{}' '\;' -print
For a unknown reason cygwin bash when it executes my script put some simple
quotes ' around my double quotes " and put some single quotes around {} and
around \;

Do you have an idea why ?

View this message in context: http://www.nabble.com/Pb-with-bash-script-under-cygwin-t1810878.html#a4935913
Sent from the Cygwin Users forum at Nabble.com.

Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/

More information about the Cygwin mailing list