bash and CSRSS consuming 100% of CPU

Linda Walsh
Sun Jun 18 21:48:00 GMT 2006

Brian Dessent wrote:
> Science Guy wrote:
>> This problem has been noted before by someone else,
>> but I followed the threads and can find no resolution. 

>> When I fire-up a cygwin bash window, everything is fine for a few minutes.
>> Then the CPU utilization on my system suddenly jumps to 100%.  Bash is
>> typically grabbing about 80% of the CPU, with almost all the rest grabbed by
>> CSRSS. 
> The problem is caused by sysinternals' process explorer injecting its
> own threads into other processes.  It was also fixed several months ago
> in cygwin.  Try a snapshot.
    I didn't see Science Guy mention procexp?  Um, hey, S.G.,
are you using Process Explorer?

    I remember the ProcExp bug, but it only happened when I tried to
show properties on a cygwin process.  I believe Mark released a
followup version within 2 weeks that fixed the bug.  It wasn't a
cygwin bug (at least not the one I'm thinking of).

    But... hey, SG, if you are using Procexp, have you tried
getting an recent version?

    Brian -- not sure I understand: some other program injects code
into the cygwin process and it's a cygwin bug that should be fixed by
a new snapshot? 

    Also, if it was fixed several months ago, would he need a snapshot:
are the snapshots that out of sync with the released version?


Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list