sshd: fork of unprivileged child failed

Larry Hall (Cygwin) reply-to-list-only-lh@cygwin.com
Mon Jun 5 12:31:00 GMT 2006


Robin Walker wrote:
> --On 04 June 2006 18:18 -0400 "Larry Hall (Cygwin)" wrote:
> 
>> Robin Walker wrote:
>>> In the Windows Application Log there are, for each failed connection
>>> attempt, entries of the form:
>>>
>>> sshd: PID xxxx: fatal: fork of unprivileged child failed.
>>
>> Did you try a recent snapshot?
> 
> If, by "snapshot", you mean System Restore Point, then the problems 
> began too long ago for a restore point still to exist.  I have been 
> searching for solutions for some months already.


No, I mean a recent Cygwin snapshot of the pending 1.5.20 release.  See
<http://cygwin.com/snapshots/>


>> Think about things that have changed about the time things stopped 
>> working
>> for you.  This includes things both a part of and external to Cygwin.
> 
> Most likely, it was a Cygwin update.  sshd worked OK during most of 
> 2005, but has not worked since I updated Cygwin early in 2006.  I don't 
> use ssh on a daily basis, and it took some time to notice that 
> connections were failing.
> 
> Is there any way I can get a previous version of cygwin1.dll to check 
> against?
> 


Use setup.exe.  But backing up may not be very easy if you have other
upgraded apps that depend on new functionality in 1.5.19.


-- 
Larry Hall                              http://www.rfk.com
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
838 Washington Street                   (508) 893-9889 - FAX
Holliston, MA 01746

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list