sshd: fork of unprivileged child failed

Robin Walker
Mon Jun 5 12:23:00 GMT 2006

--On 04 June 2006 18:18 -0400 "Larry Hall (Cygwin)" wrote:

> Robin Walker wrote:
>> In the Windows Application Log there are, for each failed connection
>> attempt, entries of the form:
>> sshd: PID xxxx: fatal: fork of unprivileged child failed.
> Did you try a recent snapshot?

If, by "snapshot", you mean System Restore Point, then the problems began 
too long ago for a restore point still to exist.  I have been searching for 
solutions for some months already.

> Please read and follow the problem reporting guidelines found at:
> <>

I couldn't see anything there that addresses this problem.  I included a 
cygcheck output in a previous post in this thread.  I have already spent 
some months struggling with this before coming to this list, and Googled 
every likely search term.  The searches show some other users had a similar 
problem, but cured it with a rebaseall.  That worked once for me, but no 

> Think about things that have changed about the time things stopped working
> for you.  This includes things both a part of and external to Cygwin.

Most likely, it was a Cygwin update.  sshd worked OK during most of 2005, 
but has not worked since I updated Cygwin early in 2006.  I don't use ssh 
on a daily basis, and it took some time to notice that connections were 

Is there any way I can get a previous version of cygwin1.dll to check 

Robin Walker (Junior Bursar), Queens' College, Cambridge CB3 9ET, UK  Tel:+44 1223 335528

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list