How come I'm still the mkgroup group?

Tim Prince
Thu Jun 1 01:06:00 GMT 2006

Larry Hall (Cygwin) wrote:
> Clifford Moravetz wrote:
>> I'm wondering why I'm still in the 'mkgroup' group even after running
>> the mkgroup and mkpasswd commands. I ran these commands like this:
>> mkpasswd -l -d > /etc/passwd
>> mkgroup -l -d > /etc/group
>> but when I run the id command I'm still in the mkgroup. Here's the
>> output from my id command:
>> uid=21522(Moravetz) gid=22162(mkgroup)
>> groups=544(Administrators),545(Users),1005(Debugger
>> Users),28009(cc_users),10513(Domain
>> Users),18698(InternetAccess_A),28014(SB-CCUltiview),22162(mkgroup)
>> It got wrapped in a few odd places because of Yahoo's rules about
>> word wrapping. I've attached the output of cygcheck as requested.
> Thank you.  It looks like your primary group ID is 22162.  It's possible
> that 'mkgroup' is having problems getting information for that group id
> from your domain.  Do you see any errors when you run 'mkgroup'?
I've not been able to get any effect from the recommended mkpasswd and 
mkgroup commands in recent years, on about 4 separate installations. 
There are no error messages, simply no effect.  I haven't seen it as an 
issue to be raised, as it didn't have any obvious negative effect.  I 
assumed it might be partly that, in the case of the laptop, operation 
both when connected and disconnected from a domain might not have any 
particular support.

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list