Similar problem (was RE: Need some help on a thread issue - is it application problem or cygthread or my installation)

Brian Hassink
Sun Dec 24 20:40:00 GMT 2006

Hmmm, I've just run into the exact same problem with an app I'm working on...

      5 [sig] mud 3264 C:\cygwin\home\admin\smudge-0.1.0\bin\smudge.exe: *** fatal error - called with threadlist_ix -1
./go: line 2:  3264 Hangup                  ./bin/smudge.exe

...but in my case, things were working fine up until I did clean build.  I then rolled back my changes, but the problem persists.  I've since tried newer and older cygwin snapshots, still with no luck.

I wasn't able to get a backtrace via gdb, but resorting to logs revealed the problem occurring when calling into to the boost file system library (specifcally, making a path iterator).  In searches on this list and google, this thread problem, when seen, seems to be somehow related to directories.

Is anyone else seeing this with the cygwin 1-5-23-2?


-----Original Message-----
From: on behalf of Brian Keener
Sent: Fri 12/22/2006 12:21 PM
Subject: Re: Need some help on a thread issue - is it application problem or cygthread or my installation
Brian Keener wrote:
> Loaded symbols for /cygdrive/c/WINDOWS/system32/dciman32.dll 
> Loaded symbols for /usr/local/bin/cygOpenThreads.dll 
>       4 [sig] osgversion 300 open_stackdumpfile: Dumping stack trace to 
> osgversi 
> on.exe.stackdump 
>  989547 [sig] osgversion 300 C:\cygwin\usr\local\bin\osgversion.exe: *** fatal 
> e 
> rror - called with threadlist_ix -1 
> Program exited with code 0400. 
> (gdb)

My apologies to the list for this.  After finally resolving this issue 
(accidentally I might add through some attempts to debug) I realize now that with 
the information I gave and the potential areas where there could have been a 
problem this list could not have helped.  As it turned out the application did 
not like being installed in directories other than its default even though it was 
supposed to support it.  Onve installed in the default location apps worked 

I just wanted to post this in case some neophyte like myself goes searching the 
archives for threadlist_ix -1 and finds my post and thinks there is some 
unresolved problem.  I still don't understand why the directory affected the 
thread but thats for another day and another group.

Again my apologies


Unsubscribe info:
Problem reports:

Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list