CPAN install of LWP::UserAgent

Alex Beamish
Sun Jan 23 18:24:00 GMT 2005


Just wondering if anyone else had problems installing LWP::UserAgent using CPAN.

After multiple attempts to install Cygwin on Windows 98, and various
adventrues about Perl running out of memory (I deleted 4G of space,
did a full defrag and expanded the page file) during CPAN install, I'm
now at the point where I'm failing the

  $r = new WWW::RebotRules::AnyDBM_File "myrobot/2.0" $file;

test. Guessing that it might be a permissions problem, I tried to
specify a path for the test file, changed

  $file = "test-$$";


  $file = "/home/tab/test-$$";

This didn't work. I tried to find or create a world-writable directory
that could be used, and was unable to do that.

The latest suggestion I received via Perl Monks
( was to bypass the
entire group of tests. I'll do that, but I wanted to see if any Cygwin
users had encountered similar problems.



Unsubscribe info:
Problem reports:

More information about the Cygwin mailing list