cron problems with windows 2003 server

Pierre A. Humblet pierre.humblet@ieee.org
Fri Jan 21 04:38:00 GMT 2005


On Thu, Jan 20, 2005 at 05:57:27PM -0800, Jay Patel wrote:
> CYGWIN_NT-5.2 hal 1.5.12(0.116/4/2) 2004-11-10 08:34 i686 unknown 
> unknown Cygwin
> 
> Logged in as Administrator I have installed the cron service with:
> cygrunsrv -I cron -p /usr/sbin/cron -a '-D' -e CYGWIN="tty ntsec 
> binmode" -d "CYGWIN cron"
> 
> The process is running, but my cron jobs for Administrator are not being 
> run. 
> 
> I have changed the group for /var/run and /etc/cron.d to 18 (SYSTEM) and 
> both directories have 1777 permissions.  I also have setup a simple test 
> to run every minute to see if it's working:
> 
> # DO NOT EDIT THIS FILE - edit the master and reinstall.
> # (/home/Administrator/test.txt installed on Thu Jan 20 17:44:39 2005)
> # (Cron version -- $Id: crontab.c,v 1.8 2004/12/21 16:14:41 corinna Exp $)
> * * * * * /usr/bin/date >> /home/Administrator/test.log
> 
> I'm guessing it's a permissions problem or some Windows user related 
> issue.  Any help in figuring this out is appreciated.  I have attached 
> the cygcheck results as requested by the cron_diagnose.sh script I've 
> been using to figure out what's going on.  Thanks.
 
Yes, and a privilege issue. 

There is now a cron-config script that should do the right thing, although
it has not been tested on Win2003...
Please try it and report any issues.

Pierre

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list