Problem running cygrunsrv with non SYSTEM accounts

Aitken, Sean Sean.Aitken@tekelec.com
Tue Jan 18 16:27:00 GMT 2005


> On Jan 18 10:01, Igor Pechtchanski wrote:
> > Ugh, top-posting...  Also, 
> <http://cygwin.com/acronyms/#PCYMTNQREAIYR>.
> > Thanks.
> 
> What about adding the "TOFU" acronym for these purposes?  Otherwise
> you're missing to critizise the fullquote.

My sincere apologies. I must admit that I'm not a huge fan of mailing
lists. I prefer forums with notification capabilities, personally.
Thanks for the tip though! Also, I'm using Outlook (*gag*) at work which
doesn't seem to have the option to not quote emails. Again, I apologize.

Regarding the problem running cygrunsrv, I appreciate the help. I have
done the following:
- Checked the event log - Nothing there except indicators of service
start attempt (and failure after I forcefully kill cygrunsrv)
- Checked for sshd.log - It's never created
- Permissions in /var/log allow for any user to write (verified)

I created a simple test service "test" that runs "/usr/bin/env" under my
domain account (with local admin privs), and should output to
"/var/log/test.log". The logfile never seems to be created. Also, the
output in the event log is:

- System: The test service was successfully sent a start control.
.. There was nothing else in the security or application log.

Are there debug symbols that I need to use WinDbg against cygrunsrv? I
hate having to go down this road as it will kill a lot of time. Any
pointers are greatly appreciated!

I'll see what I can do with tracing and debugging.. I'm not feeling very
optimistic at this point.

Thanks again!
-Sean

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list