Problem running cygrunsrv with non SYSTEM accounts

Aitken, Sean Sean.Aitken@tekelec.com
Fri Jan 14 02:32:00 GMT 2005


Hello all,
 
I have been fighting a problem with trying to run SSHD on a Windows
Server 2003 box. I have been able to narow the problem down a bit. I did
post earlier to day, but have stumbled across what appears to be a
strong lead on the solution.

Facts:
- With 'runas', I am able to start sshd with no problems using the
'sshd_server' account. I can even connect!
- I have granted all local rights (RunAsService, Token,.. Etc.) These
seemed to be configured already by the ssh-host-config program
- Running the service under the local SYSTEM account produces output in
/var/log/sshd.log
- Running the service under any other account produces NO log file!
- Permissions against sshd and required Cygwin libs aren't a problem
(since I could runas 'sshd_server' and it works fine)
- When I invoke the sshd process with RunAs, it's after establishing a
bash shell
- Permissions in /var/log allow users to write (tested with runas)

With a little (actually a LOT) experimentation, it seems as though the
'sshd_server' user is having a hard time starting things up.  When I run
as SYSTEM, I get output in the log folder..

I have tried about anything. Does anyone know of any Win2K3 settings
that would disallow certain acccounts from being worthy service runners?

Many thanks!
Sean F. Aitken

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://cygwin.com/docs.html
FAQ:                   http://cygwin.com/faq/



More information about the Cygwin mailing list